[COMPLETED] Scheduled Singapore Network Maintenance Wednesday 12th July 2023 16:45:37


Start Date: Thursday, July 13th, 2023 (Friday, July 14th, 2023 SGT)

End Date: Thursday, July 13th, 2023 (Friday, July 14th, 2023 SGT)

Time: 12:00 PM - 4:00 PM EST, (1:00 AM - 5:00 AM SGT)

Services Affected: Singapore Network

Description: Our System Operations team will be performing scheduled maintenance on the Singapore Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 1:40 PM EDT: Maintenance has been completed. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.