[COMPLETED] Singapore Network Maintenance Tuesday 11th July 2023 14:00:02


Start Date: Wednesday, June 12, 2023, EDT (Thursday, July 13, 2023 SGT)

End Date: Wednesday, July 12, 2023, EDT (Thursday, July 13, 2023 SGT)

Time: 12:00 PM EDT to 4:00PM EDT (12:00AM to 4:00AM SGT)

Description: Our System Operations team will be performing scheduled maintenance in the Singapore Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread. 

UPDATE 03:50PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.