[COMPLETED] Michigan :: Network Maintenance Thursday 15th June 2023 00:00:00


Start Date: Thursday, June 15, 2023 EDT

End Date: Thursday, June 15, 2023 EDT

Time: 12:00 AM - 4:00 AM EDT

Description: Our System Operations team will be performing scheduled maintenance in the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 3:00 AM EDT: The maintenance is still in progress. Users may experience service interruptions while the routine is performed. We appreciate your understanding and patience. We are going to keep this post updated as more news is available.

UPDATE 4:00 AM EDT: The scheduled maintenance has now been completed. Please reach out to our Support Team should you encounter any issues.