[RESOLVED] Michigan Network Maintenance Wednesday 14th June 2023 00:00:00


Start Date: Wednesday, June 14, 2023 ET 

End Date: Wednesday, June 14, 2023 ET 

Time: 12:00 AM - 04:00 AM ET 

Description: Our System Operations team will be performing scheduled maintenance in the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread. 

UPDATE 12:00 AM EDT: Our Engineers have started the maintenance. We will provide updates as more information becomes available.

UPDATE: 04:00 AM EDT: The maintenance is completed.