[COMPLETED] Michigan Network Maintenance Tuesday 13th June 2023 00:00:00


Start Date: Tuesday , June 13, 2023 EDT 

End Date: Tuesday , June 13, 2023 EDT 

Time: 00:00 AM - 04:00 AM EDT 

Description: Our System Operations team will be performing scheduled maintenance in the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread. 

UPDATE: 2:30 AM EDT: The maintenance is completed. If you are experiencing any issues, please, reach out to your support.