[RESOLVED] mi3-vz7-vm30 :: Service Interruption Tuesday 30th May 2023 05:23:52


mi3-vz7-vm30 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 5:55 AM EDT: Our System Operations team has resolved the issue. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.