Netherlands Network Maintenance Tuesday 30th May 2023 18:00:00


Start Date: Tuesday, May 30, 2023 (Wednesday, May 31, 2023 GMT+2)

End Date: Tuesday, May 30, 2023 (Wednesday, May 31, 2023 GMT+2)

Time: 6:00 PM - 10:00 PM EST (12:00 AM - 4:00 AM GMT+2)

Description: Our System Operations team will be performing scheduled maintenance in the Netherlands Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread. 

UPDATE 6:00 PM EST: The scheduled maintenance in Netherlands has begun. Updates will be provided as they become available.

UPDATE 8:18 PM EST: The scheduled maintenance has now been completed. Please reach out to our Support Team should you encounter any issues.