[RESOLVED] Multiple Nodes :: VPS Interruption Friday 26th May 2023 02:22:39


Multiple VPS nodes hosted in our Netherlands facility are currently experiencing a service interruption. Users hosted on affected servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 3:00 AM EDT: Our Systems Operations/Engineering teams have corrected this issue.