[COMPLTED] Michigan :: Network maintenance Monday 1st May 2023 23:05:22


Start Date: Monday, May 1, 2023

End Date: Tuesday, May 2, 2023

Time: 11:00 PM - 1:00AM EST

Description: Our System Operations team will be performing scheduled maintenance in the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 11:00 PM EDT: The scheduled maintenance has started. We will provide updates as they become available.

UPDATE 12:10 AM EDT: The maintenance has been completed and services are online at this time. We appreciate your patience and understanding.