[COMPLETED] Arizona Network Maintenance Thursday 20th April 2023 03:30:00


Start Date: Thursday, April 20, 2023

End Date: Thursday, April 20, 2023

Time: 3:30 AM - 7:30AM EDT

Description: Our System Operations team will be performing scheduled maintenance in the Arizona Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 03:30 AM EDT: The scheduled maintenance has started at this time. We will provide updates directly within this thread as they become available.

UPDATE 06:30 AM EDT: The maintenance is still not finished. We will post updates as we make progress. We appreciate your patience and understanding in the meanwhile.

UPDATE 7:30 AM EDT: The scheduled maintenance has now been completed. Please reach out to our support team should you encounter any issues.