[RESOLVED] MailChannels Outbound Email Interruption Thursday 30th March 2023 09:48:30


We are aware of intermittent issues with outbound email on our shared & reseller platforms. MailChannels has posted an update to their status page: https://status.mailchannels.net/incidents/n7pplbm0734y

We will continue to provide updates as they're made available.

UPDATE: MailChannels reported this as resolved.