[COMPLETED] mi3-tr101 :: Scheduled Maintenance Thursday 30th March 2023 00:00:00


Start Date: Thursday, March 30th, 2023

End Date: Thursday, March 30th, 2023

Time: 12:00 AM - 3:00 AM EST

Description: Our System Operations team will be performing scheduled maintenance on the server. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 12:00 AM EST: The scheduled maintenance has begun.

UPDATE 12:20 AM EST: The maintenance is completed.