[RESOLVED] MailChannels Outbound Email Interruption Tuesday 28th March 2023 15:19:00


We are aware of multiple reports of intermittent issues with outbound email on our shared & reseller platforms. MailChannels has posted an update to their status page: https://status.mailchannels.net/incidents/2lwnn7rlcdk2

We will continue to provide updates as they're made available.

UPDATE: MailChannels reported this as resolved.