[RESOLVED]Professional Email Service :: Intermittent Connectivity Wednesday 15th March 2023 11:38:55


Professional Email Services are currently experiencing a service interruption. Users with email services here will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 12:05 PM :: Our engineering teams and Professional Email Services vendor have now resolved this issue, we do apologise for the inconvenience caused.