[RESOLVED] mi3-ss66 :: Service Interruption Friday 10th March 2023 17:34:31


mi3-ss66 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:34PM EST: Issues on mi3-ss66 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.