[RESOLVED] Multiple servers: Outgoing mail interruption Thursday 2nd March 2023 15:09:14


MailChannels Outbound Email service is currently experiencing a service interruption. Users with email services on Shared, Reseller and Turbo servers will receive timeout errors while trying to send emails. MailChannels is actively working on the resolution. We will provide updates in this thread as more details are made available.

Updates are available on the official page here: https://status.mailchannels.net/

UPDATE 6:25PM EST: MailChannels have reported this as resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.