[RESOLVED] Multiple servers: Outgoing mail interruption Thursday 2nd March 2023 05:17:55


MailChannels Outbound Email service is currently experiencing a service interruption. Users with email services on Shared, Reseller and Turbo servers will receive timeout errors while trying to send emails. MailChannels is actively working on the resolution. We will provide updates in this thread as more details are made available.

Updates are available on the official page here: https://status.mailchannels.net/

UPDATE 06:00 AM EST: The MailChannels team has applied the fix. The outbound email service is operational again. if you are experiencing any issues, please, contact our support.