[COMPLETED] Michigan :: Network maintenance Tuesday 28th February 2023 00:00:00


Start Date: Monday, February 27, 2023

End Date: Tuesday, February 28, 2023

Time: 11:30 PM - 12:30 AM EST

Description: Our System Operations team will be performing scheduled maintenance on the server. Users will experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 11:30 PM EST, February 27: We have started the maintenance. We will post updates as we make progress. We appreciate your patience and understanding in the meanwhile.

UPDATE 2:00 AM EST, February 28: This maintenance has now been completed, please let us know if you see any issues.