[COMPLETED] Sectigo SSL :: Scheduled Maintenance Saturday 25th February 2023 19:00:00


Start Date: Saturday, February 25th, 2023

End Date: Sunday, February 26th, 2023

Time: 07:00 PM - 00:30 AM EST

Services Affected: All platforms using free Sectigo SSL certificates.

 

Description: Our vendor Sectigo anticipates that its certificate issuing platform will be unavailable for up to 12 hours. SSL certificate requests during this time will be delayed.

UPDATE 7:00PM EST: The scheduled maintenance has begun and issuing platform will be affected for up to 12 hours. We will provide updates as they become available. 

UPDATE 12:30 AM EST: The Sectigo maintenance is completed earlier than planned. All services are operational again. Find more information on https://sectigo.status.io/