Start Date: Saturday, February 4th, 2023
End Date: Saturday, February 4th, 2023
Time: 07:00 PM - 09:00 PM EST
Services Affected: All platforms using free Sectigo SSL certificates.
Description: Our vendor Sectigo anticipates that its certificate issuing platform will be unavailable for up to 2 hours. SSL certificate requests during this time will be delayed.
UPDATE 7:00 PM ET: The scheduled maintenance for Sectigo has begun. We will provide updates as they become available.
UPDATE 9:00 PM ET: The scheduled maintenance for Sectigo has been completed.