Sectigo SSL :: Scheduled Maintenance Saturday 21st January 2023 07:37:27


Start Date: Saturday, January 21st, 2023

End Date: Sunday, January 21st, 2023

Time: 11:59 PM - 02:00 AM EST

Services Affected: All platforms using free Sectigo SSL certificates.

Description: Our vendor Sectigo anticipates that its certificate issuing platform will be unavailable for up to 2 hours. SSL certificate requests during this time will be delayed.

UPDATE 7:00 PM: The Sectigo maintenance has started. We will provide updates as they become available.

UPDATE 9:00 PM EST: The Sectigo maintenance should now be completed at this time and can be confirmed via: https://sectigo.status.io/