[RESOLVED] mi3-tr101 :: Service Interruption Tuesday 17th January 2023 16:07:50


mi3-tr101 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:27PM EST: Issues on mi3-tr101 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.