[RESOLVED] Sectigo SSL Certificates :: Degraded Performance Wednesday 4th January 2023 05:27:18


Our Engineering Department is investigating multiple reports of delays in the Free SSL Certificates.  Currently we are detecting an error on Sectigo and have reported the error to both Sectigo and the cPanel Store. Unfortunately such an issue is out of our control, but we are working diligently with them supplying the information in the error logs.

We will be updating this post with any additional information as we received it.

 

UPDATE: 01/04/2023 03:00 PM EST --  Our vendor cPanel verified there is a systemic issue on their end causing delays with AutoSSL issuing and renewing certificates.

UPDATE 01/04/2023 8:16 PM EST: The cPanel development team is investigating the issue at this time. We will continue to provide updates as more information becomes available.

UPDATE 01/04/2023 11:20PM EST: cPanel is still currently working on addressing this issue. We will continue to post updates as they become available.

UPDATE 01/05/2023 03:55 AM EST: cPanel continues working on the SSL problem even though the number of errors should be decreased. We will keep this post updated as soon as we receive more information. In the meantime, please, reach out to our support if you get any troubles with the AutoSSL service.

UPDATE 01/05/2023 07:00 AM EST: According to the cPanel support, the issue with AutoSSL is resolved. Please, contact our support if you experience any difficulties. We thank you for your understanding and patience.