[RESOLVED] Multiple servers :: Service Interruption Monday 5th December 2022 14:28:14


We have received reports of websites not loading but downloading a file, affecting multiple servers. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 03:50 PM EST: Our System Operations team identified the issue, a fix will start to be implemented to all affected servers. We will provide more updates as soon as possible. 

UPDATE 5:00 PM EST: Our Engineers are still working on this, normal functionality has been restored to most websites and we are working on the rest. We will post updates as we make further progress. We sincerely appreciate your patience and understanding in this matter.

UPDATE 5:42 PM EST: All servers impacted by this incident have been fixed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.