[RESOLVED]mi3-sr5 :: Emergency Reboot Wednesday 30th November 2022 01:23:55


mi3-sr5.supercp.com is currently undergoing an emergency reboot. Users hosted on this server will experience a brief service interruption. We appreciate your patience and understanding.

UPDATE 1:35AM EDT: mi3-sr5 has been restarted and is back online.