[RESOLVED]mi3-ts2 :: Service Interruption Sunday 20th November 2022 00:06:49


Server mi3-ts2.a2hosting.com will experience a brief service interruption. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 12:10AM EDT: Our System Operations team has corrected the issue affecting the server. Services are available at this time.