[RESOLVED] Michigan Datacenter :: Network Issue Thursday 17th November 2022 18:47:34


We are aware of network issues currently linked to our Michigan Datacenter. Users hosted on some servers in Michigan will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. We sincerely apologize for any inconvenience faced in the meanwhile.

UPDATE 7:45 PM EST: Issues with Michigan Network have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.