[RESOLVED] mi3-ts6 :: Service Interruption Tuesday 8th November 2022 21:58:23


mi3-ts6 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 11:30PM EST: Issues on mi3-ts6 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.