[RESOLVED] Arizona Datacenter Maintenance Sunday 30th October 2022 03:13:23


Start Date: Sunday, October 30, 2022

End Date: Sunday, October 30, 2022

Time: 03:00 AM - 08:00 AM EDT

Description: Our System Engineering team is performing server maintenance in our Arizona Datacenters. VPS users may experience a brief service interruption while routine maintenance is performed. We appreciate your patience and understanding!

Update: 07:10 AM EDT: The maintenance is completed successfully.