Singapore DC :: Scheduled Maintenance Monday 24th October 2022 11:58:08


Date: Monday, October 24th, 2022  

Time: 12:00 PM EST - 03:59 PM EST

Server time/date: Tuesday, October 26th 12:00 AM - 03:59 AM

Description: Our System Engineering team is performing network maintenance in our Singapore Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:30 PM EDT: Our System Operations team started the scheduled maintenance. We appreciate your patience and understanding during the brief service interruption. Updates will be provided as they become available.

UPDATE 03:30 PM EDT: The maintenance is still in progress. Thanks for patience.

UPDATE 6:40 PM EDT: The maintenance has been completed.