[COMPLETED] Singapore DC :: Scheduled Maintenance Sunday 16th October 2022 15:19:01


Date: Monday, October 17th, 2022  

Time: 12:00 PM EST - 03:59 PM EST

Server time/date: Tuesday, October 18th 12:00 AM - 03:59 AM

Description: Our System Engineering team is performing a network maintenance in our Singapore Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:20 PM EDT: Our System Operations team started the scheduled maintenance. We appreciate your patience and understanding during the brief service interruption. Updates will be provided as they become available.

UPDATE 2:40 PM EDT: The maintenance is still in progress.

UPDATE 3:55 PM EDT: Maintenance has been completed. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.