[RESOLVED] mi3-ts3 :: Service Interruption Wednesday 12th October 2022 09:50:49


mi3-ts3 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 10:54 AM EDT: Issues with mi3-ts3 have now been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.