[COMPLETED] Michigan Datacenter :: Emergency Maintenance Tuesday 4th October 2022 00:00:00


Date: Tuesday, October 4th, 2022  

Time: 12:00 AM EDT - 04:00 AM EDT  

Our System Operations team is initiating an emergency maintenance in our Michigan Datacenter. Users hosted on the affected servers may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 1:00AM EDT: The maintenance is still in progress. We appreciate your continued patience and understanding.

UPDATE 2:00PM EDT: The maintenance has been completed at this time. Please do not hesitate to reach out to our Support Team should you notice any issues.