[RESOLVED] Singapore DC :: Network Interruption Monday 3rd October 2022 17:03:38


We are aware of degraded performance faced by some clients hosted in our Singapore Datacenter. Our Network Engineers are actively investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 6:45 PM EDT: Issues with Singapore Network have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.