[COMPLETED] Michigan Datacenter :: Scheduled Maintenance Monday 26th September 2022 16:31:06


Start Date: Wednesday, September 28nd, 2022

End Date: Wednesday, September 28nd, 2022

Time: 12:00 AM - 4:00 AM EDT

Description: Our System Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00AM EDT: Our System Engineering team has begun the maintenance at this time. We will provide further updates as we receive them. 

UPDATE 4:00AM EDT: Our System Engineering team has completed this maintenance.