Michigan Datacenter :: Scheduled Maintenance Saturday 1st October 2022 07:30:00


Start Date: Saturday October 01, 2022

End Date: Saturday October 01, 2022

Time: 07:30 AM - 03:00 PM EDT

Description: The Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

UPDATE 7:20AM EDT: The maintenance will begin shortly. We appreciate your patience and understanding while the maintenance is performed.

UPDATE 7:30AM EDT: The Network Engineering team has begun the maintenance at this time. We will provide further updates as we receive them. 

UPDATE 12:00 EDT: The maintenance is still in progress at this time. We will provide further updates as we receive them. 

UPDATE 5:20PM EDT: The maintenance has been completed at this time. Please do not hesitate to reach out to our Support Team should you notice any issues.