Start Date: Thursday, September 22nd, 2022
End Date: Thursday, September 22nd, 2022
Time: 12:00 AM - 4:00 AM EST
Description: Our System Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.
UPDATE 12:00AM EDT: This maintenance is now in progress. We will notify you once this has been completed.
UPDATE 4:05AM EDT: The maintenance has been completed at this time.