[RESOLVED]Michigan/Arizona Datacenter Maintenance Sunday 18th September 2022 00:16:47


Start Date: Sunday, September 18th, 2022

End Date: Sunday, September 18th, 2022

Time: 12:00 AM - 5:00 AM EDT

Description: Our System Engineering team is performing server maintenance in our Michigan and Arizona Datacenters. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 6:00AM EDT: The maintenance has been completed at this time.