[RESOLVED] Michigan Datacenter Maintenance Thursday 15th September 2022 00:00:00


Start Date: Thursday, September 15th, 2022

End Date: Thursday, September 15th, 2022

Time: 12:00 AM - 4:00 AM EST

Description: Our System Engineering team is performing server maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 01:50 AM EDT:  Our System Engineering team has completed the maintenance at this time.