Michigan/Arizona Datacenter Maintenance Sunday 11th September 2022 00:11:46


Start Date: Sunday, September 11th, 2022

End Date: Sunday, September 11th, 2022

Time: 12:00 AM - 5:00 AM EST

Description: Our System Engineering team is performing server maintenance in our Michigan and Arizona Datacenters. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00AM EDT: Our System Engineering team will begin the maintenance shortly. Further updates will be provided as they become available.

UPDATE 1:30AM EDT: The maintenance is still in progress. Brief service interruptions are may be experienced while the maintenance is performed. Thank you for your patience and understanding.

UPDATE 2:55AM EDT: Our System Engineering team is still performing maintenance. 

UPDATE 4:25AM EDT: Our System Engineering team has completed the maintenance at this time.