[RESCHEDULED] Michigan DC :: Scheduled Maintenance Thursday 8th September 2022 21:57:43


Start Date: Thursday, September 8th, 2022

End Date: Thursday, September 9th, 2022

Time: 10:00 PM - 12:00 AM EST

Description: Our System Engineering team is performing server maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 10:00 PM EDT: Our Engineers have started the maintenance. We will provide updates as more information is available in this regard.

UPDATE 10:10 PM EDT: Unfortunately for technical reasons, our team has had to postpone this maintenance. We will reschedule it at a more opportune time to ensure minimal impact. We sincerely apologize for any inconvenience and appreciate your understanding in this regard.