[RESOLVED] mi3-ss10 :: Service Interruption Friday 9th September 2022 01:00:00


mi3-ss10 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 05:33 AM EDT: This issue has now been resolved, please let us know if you are still experiencing any issues via ticket, chat or phone.