[RESOLVED] mi3-ss50 :: Service Interruption Friday 2nd September 2022 05:28:54


mi3-ss50 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 05:30 AM EDT: This issue has now been resolved, please let us know if you are still experiencing any issues via ticket, chat or phone.