[RESOLVED]Michigan/Arizona Datacenter Maintenance Saturday 27th August 2022 23:58:06


Start Date: Sunday, August 27th, 2022

End Date: Sunday, August 27th, 2022

Time: 12:00 AM EDT

Description: Our System Engineering team is performing server maintenance in our Michigan & Arizona Datacenters. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 1:30 AM EDT: The maintenance is still in progress at this time. Further updates will be provided as they are available.

UPDATE 3:30AM EDT: The maintenance has been completed at this time. All services are available.