[RESOLVED] Barracuda Email Service :: Service Interruption Thursday 18th August 2022 08:59:01


Barracuda Email Services are currently experiencing a service interruption. Users with email services here will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 9:45 AM :: Our engineering teams are still working on this issue with Barracuda and we will provide updates as we know more.

UPDATE As of 11:30 AM :: Our engineering teams are still working on this issue with Barracuda, unfortunately, we do not have an ETA but we will update you as we know more.

UPDATE As of 12:20 AM :: Our engineering teams are still working on this issue with Barracuda, we will update you as we know more.

UPDATE As of 1:40 PM :: Our engineering teams and Barracuda have now resolved this issue, we do apologise for the inconvenience caused.