Singapore Datacenter :: Service Interruption Friday 5th August 2022 17:29:56


Servers within our Singapore data centre are currently experiencing a service interruption. Users hosted within the Singapore data centre will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 10:40PM EDT: Our System Operations team continues to work toward resolving the interruption. We will provide updates as they're made available.

UPDATE 12:15AM EDT: Our Engineers are still working on this issue and monitoring the service. We will update the thread once more information is available in this regard. 

UPDATE 12:16AM EDT: Issues affecting the Singapore data centre have been resolved. Please do not hesitate to reach out to our support team should you encounter any issues.