[COMPLETED] Michigan Datacenter :: Scheduled Maintenance Monday 25th July 2022 20:00:00


Start Date: Tuesday, July 26th, 2022

End Date: Tuesday, July 26th, 2022

Time: 12:00 AM - 04:00 AM EDT

Description: Our Network Engineering team is performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:50AM EDT: The maintenance has now been completed. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.