[COMPLETED] mi3-ss14 :: Scheduled Maintenance Thursday 28th July 2022 21:00:00


Start Date: July 29th (Friday)

Time: 1:00 AM EDT

Services Affected:

mi3-ss14.a2hosting.com

Description: Our System Operations team will be performing scheduled maintenance on mi3-ss14.a2hosting.com. Users may experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 01:15 AM EDT: The maintenance has been completed successfully. If you experience any issues with the service, please do not hesitate to contact our live support for assistance.