[RESOLVED]nlss3.a2hosting.com - service interruption Thursday 10th May 2018 20:25:27


nlss3.a2hosting.comĀ is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 12:50 AM Eastern: The server is back online now