[RESOLVED] ssr13 :: Service Interruption Thursday 21st July 2022 13:24:19


ssr13 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:40 PM EDT: Our Staff are continuing to work on the server. We will post updates as more information becomes available.

UPDATE 6:00 PM EDT: Issues on ssr13 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.